Exam Insights - Password Reset Email Delivery – Incident details

Password Reset Email Delivery

Resolved
Partial outage
Started about 2 months agoLasted about 3 hours

Affected

Authentication

Partial outage from 10:13 PM to 12:52 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are currently experiencing a delay in password reset email delivery due to temporary rate limits imposed by our email provider. Our team is actively addressing the issue, and we expect it to be resolved soon. Thank you for your understanding and patience.